Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Deploying BI platform on JBoss

  1. #1
    Join Date
    Dec 2011
    Posts
    9

    Default Deploying BI platform on JBoss

    I have downloaded the following distributions of Pentaho:

    1. pentaho-bi-suite-4.1.0-GA-x64 - Enterprise edition with a trial period
    2. biserver-ce-3.10.0-stable - Community edition

    I wish to deploy the pentaho.war on a JBoss 4.2 Enterprise Platform server.

    I read through the post http://forums.pentaho.com/showthread...o-3-5-on-jboss

    However, I could not understand - where do I get the penatho.war and pentaho-solutions.war from? I copied the pentaho directory from tomcat/webapps and renamed it as pentaho.war. Followed the configurations suggested in the above post but it did not yield any positive result.

    Can some one please help me here?

    Thanks in advance.

  2. #2
    Join Date
    Dec 2011
    Posts
    9

    Default

    Ok. Took a few steps forward. I am working on 64-bit Windows 7, JBoss EA 4.2.0, Oracle10g

    I downloaded biserver-manual-ce-3.9.0-RC1, and manually built the pentaho.war

    1. I set the absolute path of pentaho-solutions in pentaho.war/WEB-INF/web.xml
    2. Updated the <absolute path>/biserver-manual-ce/pentaho-solutions/system/applicationContext-spring-security-hibernate.properties

    I set the connection setting of my Oracle 10g database there

    3. I put the ojdbc14.jar in WEB-INF/lib dir for "oracle.jdbc.driver.OracleDriver"

    I started the JBoss. And following are the errors now:

    23:08:14,523 ERROR [Logger] Error: Pentaho
    23:08:14,523 ERROR [Logger] misc-org.pentaho.platform.engine.core.system.PentahoSystem: PentahoSystem.ERROR_0014 - Error while trying to execute startup sequence for org.pentaho.platform.plugin.action.mondrian.MondrianSystemListener
    org.pentaho.platform.api.engine.PentahoSystemException: PentahoSystem.ERROR_0014 - Error while trying to execute startup sequence for org.pentaho.platform.plugin.action.mondrian.MondrianSystemListener
    at org.pentaho.platform.engine.core.system.PentahoSystem.notifySystemListenersOfStartup(PentahoSystem.java:348)
    at org.pentaho.platform.engine.core.system.PentahoSystem.notifySystemListenersOfStartup(PentahoSystem.java:322)
    at org.pentaho.platform.engine.core.system.PentahoSystem.init(PentahoSystem.java:289)
    at org.pentaho.platform.engine.core.system.PentahoSystem.init(PentahoSystem.java:206)

    On accessing the pentaho page, it shows the error on the browser:
    One or more system listeners failed. These are set in the systemListeners.xml. PentahoSystem.ERROR_0014 - Error while trying to execute startup sequence for org.pentaho.platform.plugin.action.mondrian.MondrianSystemListener


    Please help someone.

  3. #3
    Join Date
    Dec 2011
    Posts
    9

    Default

    Finally got the deployment successfully done.

    I got errors with MondrianSystemListener and KettleSystemListener. To overcome that, I commented the respective line in pentaho-solutions/system/systemListeners.xml
    I am not sure how much of a problem I have solved or created for myself there. Would eventually know what works and what does not due to those commented lines.

    The other configuration I did was to add quartz-ds.xml in the JBoss\server\default\deploy dir with credentials to my Oracle database having Quartz schema.

    The "Pentaho User Console" is up and running now.

  4. #4

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.