Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: FoodMart database installation problem

  1. #1
    Join Date
    Dec 2011

    Default FoodMart database installation problem

    Hi All

    I downloaded the latest stable release of Mondrian (mondrian-
    I wanted to install the test data set called FoodMart on MySQL (linux) and followed the instructions carefully.
    I created the foodmart user with all permissions for the foodmart database.
    I intended to use MondrianFoodMartLoader to populate the database but when I used the following command
    java -cp "/mondrian/lib/mondrian.jar:/mondrian/lib/log4j.jar:/mondrian/lib/commons-logging.jar:/mondrian/lib/eigenbase-xom.jar:/mondrian/lib/eigenbase-resgen.jar:/mondrian/lib/eigenbase-properties.jar:/usr/local/mysql/mysql-connector-java-5.0.5-bin.jar"
    -verbose -tables -data -indexes

    I received errors stating there were missing jar files. I downloaded from the web the files missing from /mondrian/lib which were stated in the error message. After MondrianFoodMartLoader stopped complaining about missing jar files I received the following error message
    Exception in thread "main" java.lang.VerifyError: (class: mondrian/olap/Util, method: matches signature: (Lorg/olap4j/mdx/IdentifierSegment;Ljava/lang/StringZ) Incompatible argument to function at mondrian.test.loader.MondrianFoodMartLoader.<clinit>(
    Could not find the main class: mondrian.test.loader.MondrianFoodMartLoader. Program will exit.

    I also tried using jar files I found after exploding the mondrian.war file (log4j-1.2.8.jar ….) but this did NOT help.
    I saw that FoodMartCreateData.sql contains the insert statements for the FoodMart db, but no schema for it. The FoodMart.xml seems to contain the schema but I cannot simply use it for creating tables without using MondrianFoodMartLoader, which simply doesn’t work.

    I also created a java project for Mondrian on eclipse and when I ran MondrianFoodMartLoader .java I received an error on line 100,
    java.lang.NoClassDefFoundError: edu/emory/mathcs/backport/java/util/concurrent/ThreadFactory
    at mondrian.test.loader.MondrianFoodMartLoader.<clinit>(
    Caused by: java.lang.ClassNotFoundException:
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 1 more
    Exception in thread "main"

    Which is
    private static final String nl =;
    It does not seem to be related to threading and clicking the link to line 100 results in an error message stating that 100 is not a valid line number in this file.

    I am using JDK version 1.6.0_17 on linux.
    “>java -version
    java version "1.6.0_17"
    OpenJDK Runtime Environment (IcedTea6 1.7.5) (rhel-1.16.b17.el5-x86_64)
    OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)”

    And on my PC (windows 7)
    java version "1.6.0_21"
    Java(TM) SE Runtime Environment (build 1.6.0_21-b07)
    Java HotSpot(TM) 64-Bit Server VM (build 17.0-b17, mixed mode)

    My eclipse is using JDK with 1.6 compliance (could not get more details than that)

    I am really looking forward to seeing Mondrian system capabilities.

    Please help me in any way you can.
    Thanks in advance.

  2. #2
    Bill Back Guest


    Try using the instructions on this site instead. Much easier. http://business-intelligence.phi-int...sql-setup.html

  3. #3


    It's sad to say that after a year and a half (now at version 3.5.0), all of these problems still exist.

  4. #4
    Join Date
    Sep 2013


    Try using olap4j.jar instead of olap4j-jdk.jar. olap4j.jar is bundled in mondrian.war


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.