Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: ERROR [MultitableDatasourceService] org.pentaho.di.core.exception.KettleDatabaseExcep

  1. #1
    Join Date
    Jul 2011
    Posts
    22

    Default ERROR [MultitableDatasourceService] org.pentaho.di.core.exception.KettleDatabaseExcep

    Hi Guys!

    This is my workstation configuration:
    Windows XP SP3 x64 (Unfortunately on windows )
    PostgreSQL 9.1
    This BI SERVER:
    http://sourceforge.net/projects/pent...e.zip/download


    I followed all the installation steps in http://ci.pentaho.com/view/Documenta...all_ziptar.pdf to create PostgresSQL Repository
    excepts the steps about auditing because the pattern that was specified /pentaho/server/biserver-ee/pentaho-solutions/admin/audit/dialects/
    postgresql/ doesn't match \biserver-ce-3.10.0-stable\biserver-ce\pentaho-solutions\admin and I don't have "audit" e "dialects" directories, however the server runs.

    The problem is that I'm trying to connect to a PostgreSQL 9.1 datasource
    In Tomcat Console I read this:
    ERROR [MultitableDatasourceService] org.pentaho.di.core.exception.KettleDatabaseException about the query that it throws select * from table_name limit 1
    the correct query shoulbe with the schema name specified. For istance select * from schema_name.table_name

    Name:  bug.jpg
Views: 41
Size:  37.3 KB

    (I have already tried with postgresql 8.4 on Linux machine but the result is the same )

    Unfortunately doesn't retrieve the keyfield from PostgreSQL 9.1 data source.

    How Can I resolve this problem?

    thanks to all

    Regards

    P.S.

    Which is the best way to create dimension table and fact table using kettle ? I usually use "table input" followed by lookup/upgrade dimension step and table output
    And which is the best software to design by using DFM Dimensional Fact Model or Star Schema?
    Last edited by Kettle; 02-22-2012 at 03:28 AM.

  2. #2
    Join Date
    Jul 2011
    Posts
    22

    Default Workaround

    If I put the tables in PostgreSQL PUBLIC schema I solved but It's not really correct!

  3. #3
    Join Date
    Jul 2011
    Posts
    22

    Default Solved

    You have to define the parameter CurrentSchema with the Name of your Schema

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.