Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Got error when deploy report to pentaho server

  1. #1
    Join Date
    Oct 2010
    Posts
    24

    Question Got error when deploy report to pentaho server

    Hi there
    I am pentaho starter, I created a new report with postgresql database connection, report running is good.
    I also installed the Pentaho server. I have put the postgresql jar file into both folders of "Pentaho\Server\administration-console\jdbc" and "Pentaho\Server\biserver-ce\tomcat\lib". I have run the server and all existing reports are looked good.
    But when I published the new report to the server, I got below error:

    java.lang.IllegalStateException
    at org.pentaho.reporting.libraries.pensol.vfs.FileInfo.<init>(FileInfo.java:77)
    at org.pentaho.reporting.libraries.pensol.vfs.FileInfoParser.startElement(FileInfoParser.java:136)
    at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)
    at org.apache.xerces.parsers.AbstractXMLDocumentParser.emptyElement(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanStartElement(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
    at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
    at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
    at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
    at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
    at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
    at org.pentaho.reporting.libraries.pensol.vfs.SolutionFileModel.performParse(SolutionFileModel.java:279)
    at org.pentaho.reporting.libraries.pensol.vfs.LocalFileModel.refresh(LocalFileModel.java:95)
    at org.pentaho.reporting.designer.extensions.pentaho.repository.actions.ValidateLoginTask.validateLoginData(ValidateLoginTask.java:83)
    at org.pentaho.reporting.designer.extensions.pentaho.repository.actions.ValidateLoginTask.run(ValidateLoginTask.java:46)
    at java.lang.Thread.run(Unknown Source)

    The user name and password I used is joe/password

    I appreciate any assistants and thanks in advance.
    jenny

  2. #2
    Join Date
    Nov 2009
    Posts
    687

    Default

    When you can't publish to the server:
    Did you changed publisher_config.xml and put the right password in it? You can changed the file in ..\pentaho-solutions\system
    Did you make an database connection in the Pentaho Administration Console?

  3. #3
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    and does the user who tries to publish have admin access on the server?
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  4. #4
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    Btw: What is your PRD and your BI-Server version number?
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  5. #5
    Join Date
    Oct 2010
    Posts
    24

    Default

    Thanks Johanhammink, Taqua
    Yes I have not set up publisher password. It is working now.
    Thanks so much.
    Jenny

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.