Hi everybody,

We are trying to run a simple job from a simple main java class like that:

Code:
 

public static void main(String[] args) throws KettleException, KettleXMLException {
      

        KettleEnvironment.init();

        JobMeta jobMeta = new JobMeta("D:/workspace/Testkettle/src/parsertask.kjb", null);

       
        
// Create the Job Instance
        Job job = new Job(null, jobMeta);
        job.getJobMeta().setInternalKettleVariables(job);



        job.setName(Thread.currentThread().getName());

        // Start the Job, as it is a Thread itself by Kettle.
        job.start();
        job.waitUntilFinished();

        if (job.getResult() != null && job.getResult().getNrErrors() != 0) {
            throw new RuntimeException("IF: There were errors during job execution.");
        }
        // Now the job task is finished, mark it as finished.
        job.setFinished(true);
        ;

        job.waitUntilFinished();

    }
This code runs well in some computer in where we have all user privileges. But in others the program runs under restricted privileges. In these cases we always get the same error:

Code:
Unable to list jar files in plugin folder '%USERPROFILE%\.kettle\plugins'
Unable to get VFS File object for filename '%USERPROFILE%\.kettle\plugins' : Invalid URI escape sequence "%US".
Unable to get VFS File object for filename '%USERPROFILE%\.kettle\plugins' : Invalid URI escape sequence "%US".

    at org.pentaho.di.core.plugins.PluginFolder.findJarFiles(PluginFolder.java:117)
    at org.pentaho.di.core.plugins.PluginFolder.findJarFiles(PluginFolder.java:96)
    at org.pentaho.di.core.plugins.BasePluginType.findAnnotatedClassFiles(BasePluginType.java:219)
    at org.pentaho.di.core.plugins.BasePluginType.registerPluginJars(BasePluginType.java:485)
    at org.pentaho.di.core.plugins.BasePluginType.searchPlugins(BasePluginType.java:105)
    at org.pentaho.di.core.plugins.PluginRegistry.init(PluginRegistry.java:410)
    at org.pentaho.di.core.KettleEnvironment.init(KettleEnvironment.java:80)
    at test.main(test.java:13)
Caused by: org.pentaho.di.core.exception.KettleFileException:
The error appears when execute KettleEnvironment.init(). We believe the problem its related with a default directory folder of plugins and we tried to change the directory folder of plugin modifying kettle.properties (inclusive adding KETTLE_PLUGIN_FOLDER) but not work.

We had one previous exception with the shared.xml file but, in these case we solved the exception changing the suitable property "KETTLE_SHARED_OBJECTS" within kettle.properties file.

The Job runs perfect but always appear the exception. Anybody knows how to solve that problem?

Thanks.