Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Pentaho installation with postgres and Windows

  1. #1
    Join Date
    May 2012
    Posts
    2

    Default Pentaho installation with postgres and Windows

    Hi,

    I have some problems with pentaho installation. When i try to access to http://localhost:8080/pentaho the following error occurs:

    14:47:31,032 ERROR [Logger] Error: Pentaho
    14:47:31,032 ERROR [Logger] misc-org.pentaho.platform.engine.core.system.PentahoSystem: PentahoSystem.ERROR_0014 - Error mientras se intentaba ejecutar la secuencia de arranque por org.pentaho.platform.plugin.action.mondrian.MondrianSystemListener
    org.pentaho.platform.api.engine.PentahoSystemException: PentahoSystem.ERROR_0014 - Error mientras se intentaba ejecutar la secuencia de arranque por org.pentaho.platform.plugin.action.mondrian.MondrianSystemListener
    at org.pentaho.platform.engine.core.system.PentahoSystem.notifySystemListenersOfStartup(PentahoSystem.java:350)
    at org.pentaho.platform.engine.core.system.PentahoSystem.notifySystemListenersOfStartup(PentahoSystem.java:324)
    at org.pentaho.platform.engine.core.system.PentahoSystem.init(PentahoSystem.java:291)
    at org.pentaho.platform.engine.core.system.PentahoSystem.init(PentahoSystem.java:208)
    at org.pentaho.platform.web.http.context.SolutionContextListener.contextInitialized(SolutionContextListener.java:137)
    at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4135)
    at org.apache.catalina.core.StandardContext.start(StandardContext.java:4630)
    at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
    at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
    at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:546)
    at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:637)
    at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:563)
    at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:498)
    at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1277)
    at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:321)
    at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
    at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
    at org.apache.catalina.core.StandardHost.start(StandardHost.java:785)
    at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
    at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:445)
    at org.apache.catalina.core.StandardService.start(StandardService.java:519)
    at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
    at org.apache.catalina.startup.Catalina.start(Catalina.java:581)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
    Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.pentaho.platform.repository.hibernate.HibernateUtil
    at org.pentaho.platform.repository.solution.dbbased.DbBasedSolutionRepository.internalGetRootFolder(DbBasedSolutionRepository.java:968)
    at org.pentaho.platform.repository.solution.dbbased.DbBasedSolutionRepository.init(DbBasedSolutionRepository.java:112)
    at org.pentaho.platform.repository.solution.dbbased.DbBasedSolutionRepository.<init>(DbBasedSolutionRepository.java:97)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
    at java.lang.Class.newInstance0(Class.java:355)
    at java.lang.Class.newInstance(Class.java:308)
    at org.pentaho.platform.engine.core.system.objfac.AbstractSpringPentahoObjectFactory.instanceClass(AbstractSpringPentahoObjectFactory.java:78)
    at org.pentaho.platform.engine.core.system.objfac.AbstractSpringPentahoObjectFactory.retreiveObject(AbstractSpringPentahoObjectFactory.java:117)
    at org.pentaho.platform.engine.core.system.objfac.AbstractSpringPentahoObjectFactory.get(AbstractSpringPentahoObjectFactory.java:72)
    at org.pentaho.platform.engine.core.system.PentahoSystem.get(PentahoSystem.java:557)
    at org.pentaho.platform.engine.core.system.PentahoSystem.get(PentahoSystem.java:533)
    at org.pentaho.platform.plugin.action.mondrian.MondrianSystemListener.loadMondrianProperties(MondrianSystemListener.java:60)
    at org.pentaho.platform.plugin.action.mondrian.MondrianSystemListener.startup(MondrianSystemListener.java:46)
    at org.pentaho.platform.engine.core.system.PentahoSystem.notifySystemListenersOfStartup(PentahoSystem.java:342)
    ... 28 more


    The version is "biserver-ce-4.5.0-stable"
    Can anyone help me?
    Tanks os much

  2. #2
    Join Date
    Dec 2010
    Posts
    304

    Default

    Hi,
    I think it can't connect to hibernate database, you've probably missed some step during the configuration for postgres ...

    1) put postgres jdbc driver in Pentaho webapp lib
    2) set connection parameters to hibernate and quartz in META-INF/context.xml
    3) in pentaho-solution/system/hibernate/hibernate-settings.xml: <config-file>system/hibernate/postgresql.hibernate.cfg.xml</config-file> (if hibernate is on postgres)
    4) in pentaho-solution/system/hibernate/postgresql.hibernate.cfg.xml: set connection parameters to hibernate
    5) in pentaho-solution/system/simple-jndi/jdbc.properties: set connection parameters to hibernate

  3. #3
    Join Date
    May 2012
    Posts
    2

    Default

    Hi lukolap,

    First of all, thanks for your answer.
    I didn't make any change in "jdbc.properties" file.
    Now, I have changed this file and obtain de same error.

    Thansk.

  4. #4
    Join Date
    Feb 2007
    Posts
    25

    Default

    Dealing with the same issue tryign to change to an Oracle database. Wish I could find out a solution, but so far I've tried about a dozen to no avail.

  5. #5
    Join Date
    Apr 2012
    Posts
    1

    Default Figured it out.

    Quote Originally Posted by stanatedj View Post
    Dealing with the same issue tryign to change to an Oracle database. Wish I could find out a solution, but so far I've tried about a dozen to no avail.
    I've been working on this problem for about a week. Finally figured it out. I was getting the NoClassDefFoundError: HibernateUtil.class when deploying on WebLogic and Oracle DB backend. Turns out it had nothing to do with the Oracle backend, I tried deploying with the default HSQLDB backend, and got the same error.

    Turns out it had to do with WebLogic and class loading based on the tip from: http://forum.springsource.org/showth...l.ast.HqlToken

    The trick for me was to add a weblogic.xml file to the WEB-INF directory with the contents:
    Code:
    <weblogic-web-app>    
        <container-descriptor>
            <prefer-web-inf-classes>
                true
            </prefer-web-inf-classes>
        </container-descriptor>
    </weblogic-web-app>
    After seeing too many threads with this same question and no answer, I decided I owe it to whatever future soul tries to deploy Pentaho on WebLogic.

    Further details: I just used the 3.10 manual release and built it using the ant jboss-no-portal target. WebLogic 10.3.5.0. Oracle 11g. Following the steps to use Oracle Backend as stated here:
    https://docs.google.com/document/edi...h.5b554e16194b

    I also created the hibernate and quartz Data Sources in WebLogic, although I'm not sure if that was necessary.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.