Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Installing Pentaho with JBoss

  1. #1
    Join Date
    Jan 2009
    Posts
    28

    Default Installing Pentaho with JBoss

    Hi,

    First, I want to comment our requiremnets:

    - Web Server: Jboss (5.1.0)
    - Pentaho 3.9
    - Server Database: Oracle 11g. The tables of hibernate and tables of data is in the same database.


    I have done a manual deploy and we have configured the next files to connect to the database:

    - pentaho-solutions/system/applicationContext-spring-security-jdbc.xml (via JDBC).
    - pentaho-solutions/system/hibernate/oracle10g.hibernate.cfg.xml (via JDBC)
    - server/default/deploy/pentaho-ds.xml: In this file, I have got the JNDI.


    Now, I want to change the configuration to connect to the database "hibernate" using JNDI. To connect using JNDI I have changed the files “applicationContext-spring-security-jdbc.xml” and “oracle10g.hibernate.cfg.xml”, but I have got an error when an user log in to the application. Next, I indicate some error messages:

    ERROR [STDERR] (main) SLF4J: Class path contains multiple SLF4J bindings.
    ERROR [STDERR] (main) SLF4J: Found binding in [vfszip:/C:/jboss-5.1.0.GA/common/lib/slf4j-jboss-logging.jar/org/slf4j/impl/StaticLoggerBinder.class]
    ERROR [STDERR] (main) SLF4J: Found binding in [vfszip:/C:/jboss-5.1.0.GA/server/default/deploy/pentaho.war/WEB-INF/lib/slf4j-log4j12-1.6.1.jar/org/slf4j/impl/StaticLoggerBinder.class]
    java.sql.SQLException: You cannot commit with autocommit set!
    ERROR [HibernateUtil] HIBUTIL.ERROR_0008 - [es_53] commitTransaction() failed. org.hibernate.TransactionException: JDBC commit failed

    I have specify the property "<property name="connection.autocommit">false</property>", but the error persist.

    I have attached the file log to see the error complete. log.lo.log

    Can you say me how can I resolve this problem, please?

    Thank you, Regards

  2. #2
    Join Date
    Jan 2009
    Posts
    28

    Default

    I have advanced with this problem.

    An error appear when an user access to the application first time. If an user access after the message error not is registered. The application works correctly.

    I have attached the log file and the configuration files.

    Attachment 8799

  3. #3
    nbaker Guest

    Default

    SLF (http://www.slf4j.org/) is a logging facade we're using more and more as it works around some of the traditional ClassLoader issues with Log4J and JCL. It comes in an api jar and an impl jar. We ship with the SLF-to-Log4J impl in the war as you see in your log. Looks like JBoss comes with another impl in it's common directory. If you want the error to go away, you'll have to remove one or the other.

  4. #4
    nbaker Guest

    Default

    Not sure about the hibernate autocommit issue. I'll look around and see if we've run into it before.

  5. #5
    nbaker Guest

    Default

    Try this in your DS file:

    <connection-property name="auto-commit">false</connection-property>

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.