Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: Problem with Heat Grid - Colors and missing value

  1. #1
    Join Date
    Jun 2011
    Posts
    18

    Question Problem with Heat Grid - Colors and missing value

    Hello,
    We're facing a problem (or a bug I don't know) regarding Heat Grids.

    The colors which are supposed to show the variation between the smallest and biggest values don't show up if there is one missing value in the row.
    The missing color is displayed correctly, but none of the other in the same row.

    Here is a screenshot that perfectly shows the problem.
    Name:  heatgrid.jpg
Views: 188
Size:  25.2 KB
    For the 2 rows with no missing value, everything is fine.
    For the other row where there is at least one missing value, it displays the pinkish color (which is ok) for that cell but no color for the other cells on the same row...

    Any idea of what's going on ?

  2. #2
    Join Date
    Mar 2012
    Posts
    645

    Default Problem with Heat Grid - Colors and missing value

    Hi, I think this is a bug that has already been fixed.

    It can be confirmed by checking the version of your CCC script, located at:

    pentaho-solutions/system/pentaho-cdf/js/lib/CCC/pvc-d1.0.js

    (old versions of CCC had no version stamp in the first line of the file)

    If you send me the file I can check if this is the case.

  3. #3
    Join Date
    Jun 2011
    Posts
    18

    Default

    Looks like you're right.
    There is no version stamp in the first line of that file.
    So, my guess is a ctools installer.sh would fix it ?

  4. #4
    Join Date
    Mar 2012
    Posts
    645

    Default

    Yes, it should fix it.
    Notice, though, that there might exist breaking changes, from your version to the most recent CCC version.
    If that is a concern, you might instead try to fix that specific error.
    I can help you with that, if you'd like. I'll need your current script for that :-) .

  5. #5
    Join Date
    Jun 2011
    Posts
    18

    Default

    Ok,
    I had another server (let's call it server2) on which I could proceed with the update.
    Then I simply copied the .js you mentionned to server1, same place.
    I restarted Pentaho but it didn't do the trick.
    If there another file I should have copied ?

    I know worst case scenario is to test all my other stuff to see if nothing is broken on the new version but I'd rather not do that for now....

  6. #6
    Join Date
    Jul 2007
    Posts
    2,498

    Default

    If you can't be bothered to install the latest versions, you can't certainly expect us to be bothered to debug an old version you have, right?
    Pedro Alves
    Meet us on ##pentaho, a FreeNode irc channel

  7. #7
    Join Date
    Mar 2012
    Posts
    645

    Default

    Please make sure you have the lastest script version on the browser by checking if the timestamp can be seen in the debugger - it can be a cache problem.
    Please also try updating the CTOOLS with "-b dev" option, and see if it still happens.

    As far as the tests I've made can tell, I cannot reproduce the problem you show.

    If the problem persists, then something else must be wrong. I would then invite you to the ##pentaho IRC channel (my nick is DuarteLeao), where we can try to analyze your use case and figure it out.

  8. #8
    Join Date
    Jun 2011
    Posts
    18

    Default

    Pedro,
    Sorry if you thought I was expecting a personalized debug for an old version. This is not the case, and trust me I appreciate both the support and the great products you and your team deliver.
    Thanks DuarteLeao for your efforts in helping me.
    The preferrable option on the long term was to update the ctools anyway. And it did fix my heat grid problem. I am now testing the rest of my dashboards to check if there is anything broken but at first glance it seems alright.
    Thanks again

  9. #9
    Join Date
    Jul 2007
    Posts
    2,498

    Default

    Glad it's fixed!
    Pedro Alves
    Meet us on ##pentaho, a FreeNode irc channel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.