Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Public Schedule in PUC

  1. #1
    Join Date
    Jun 2012
    Posts
    11

    Default Public Schedule in PUC

    After I have created a public schedule from Pentaho Administration Console (from the scheduler tab), I am unable to view the same from the Pentaho User Console when I log in with a credential that does not have admin privilege (for instance Suzy / Tiffany).
    My understanding tells me that the Public Schedule is a list of all public schedules set by the administrator from the Pentaho Administration Console. A user without admin privilege can run a public schedule manually, although cannot change its interval through the Pentaho User Console.
    However, my problem lies in the fact that I do ot see a single public schedule as set by the administrator in the Pentaho Administration console.
    I will be really glad if someone could clarify the point.
    Thanks..

  2. #2
    Join Date
    Apr 2009
    Posts
    337

    Default

    You must either be a owner of that file/folder, else login as joe, and provide rights over that object which you want to schedule to the givn user/role.. Eg: Login as joe, right click on steel-wheels -> properties, select share, add Suzy/Tiffany/XYZ user or role. And then check create/update/execute/schedule privileges to the user.
    Regards,
    Madhu

  3. #3
    Join Date
    Jun 2012
    Posts
    11

    Default

    Thanks Madhu, your suggestion worked!!!
    Last edited by amrita333; 06-15-2012 at 01:32 AM.

  4. #4
    Join Date
    Jun 2012
    Posts
    11

    Default

    I would like to bring up another issue that I am facing...

    I have created a public schedule from the administration console (for instance PS1) and also selected some files (.prpt files) in the Selected Files tab.
    When I log in as a user without admin privileges like suzy / tiffany, after doing right click on the required .prpt file (which is included in the selected files of PS1), and clicking on schedule, I see the subscription drop down. I suppose I should be able to see the public schedule created in the admin console (PS1) in the subscriprtion drop down evry time I schedule the report. But I don't see PS1 every time. There are times when I can see it in the drop down, but mostly I don't.

    I am having to manually include PS1 after logging in as joe (or other user aith admin privilege) by doing a right click on each of the reuired .prpt files -> clicking on properties -> Advanced and then checking on the Public Schedule check box. However, all these .prpt files had been initially included in the Selected Files of the public schedule (PS1 in this case) in administration console.

    Could someone please confirm if this is an expected behaviour?
    Last edited by amrita333; 06-15-2012 at 03:13 AM.

  5. #5
    Join Date
    Jun 2012
    Posts
    11

    Default

    Quote Originally Posted by amrita333 View Post
    I would like to bring up another issue that I am facing...

    I have created a public schedule from the administration console (for instance PS1) and also selected some files (.prpt files) in the Selected Files tab.
    When I log in as a user without admin privileges like suzy / tiffany, after doing right click on the required .prpt file (which is included in the selected files of PS1), and clicking on schedule, I see the subscription drop down. I suppose I should be able to see the public schedule created in the admin console (PS1) in the subscriprtion drop down evry time I schedule the report. But I don't see PS1 every time. There are times when I can see it in the drop down, but mostly I don't.

    I am having to manually include PS1 after logging in as joe (or other user aith admin privilege) by doing a right click on each of the reuired .prpt files -> clicking on properties -> Advanced and then checking on the Public Schedule check box. However, all these .prpt files had been initially included in the Selected Files of the public schedule (PS1 in this case) in administration console.

    Could someone please confirm if this is an expected behaviour?
    Hi! Could someone please provide a solution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.