Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: Saiku chart to Dashboard

  1. #1
    Join Date
    Mar 2011
    Posts
    140

    Lightbulb Saiku chart to Dashboard

    Hello everyone,

    I'm facing a weird issue. I'm using saiku to generate the right chart. When I'm happy I copy and paste the generated MDX query to create a dashboard. This was working fine untill now. The chart that I want is showing fine in saiku, but isn't showing at all in my dashboard or it is showing, but not the way saiku is displaying it.


    The MDX query I use is comparable with:

    SELECT
    NON EMPTY CrossJoin({[Measures].[Quantity]}, [Time].[Years].Members) ON COLUMNS,
    NON EMPTY {Hierarchize({[Markets].[Country].Members})} ON ROWS
    FROM [SteelWheelsSales]


    If I try to create a barchart with this query of the SteelWheel example, I'm getting the same problem. In saiku I get the barchart I want, but the barchart isn't displaying at all on my dashboard.

    What is the problem ? Do I need to activate some properties on the chart ?


    Thanks in Advance !

  2. #2
    Join Date
    Mar 2011
    Posts
    140

    Default

    Hello,

    Still facing this issue.

    To explain the problem better I've added some screenshots:

    MDX:
    SELECT
    NON EMPTY CrossJoin({[Measures].[Quantity]}, [Time].[Years].Members) ON COLUMNS,
    NON EMPTY {Hierarchize({[Markets].[Country].Members})} ON ROWS
    FROM [SteelWheelsSales]

    In Saiku (the way I want the chart):
    http://s11.postimage.org/9nb1i9xwj/saiku_chart.jpg

    How to get the chart in my dashboard ? What I tried (with no succes) was:

    - Layout, one of the templates
    - Data Source: MDX over Jndi , with the above query.
    - Components CCC Bar Chart with the default values

    However, it is not displaying anything:
    http://s13.postimage.org/rskx3ew2v/dashbpard_chart.jpg

  3. #3

    Default

    Hi,

    Firts... There is any JS error?
    If not... u have to review ur steps... like...

    1 - The CDA related with this dashboard is working? (U can open in preview and see the data in table mode);
    2 - The Chart is related with a layout component? ("HtmlObject" property of the chart)? Can u see its designated struture in DOM? (firebug if u have it)
    3 - The datasource property of the chart is filled with the ds that u generate?
    4 - The Chart have a height property?

  4. #4
    Join Date
    Mar 2011
    Posts
    140

    Default

    Hello dguiarj,

    I've tried your suggestions, but everything seems to be properly set:

    Firts... There is any JS error?

    Everyting seems to be Ok:
    http://s8.postimage.org/b3o0xlhg5/st...ipt_errors.jpg


    1 - The CDA related with this dashboard is working? (U can open in preview and see the data in table mode);

    Seems to be fine to me:
    http://s8.postimage.org/f1ban049h/step1_cda_data.jpg


    2 - The Chart is related with a layout component? ("HtmlObject" property of the chart)? Can u see its designated struture in DOM? (firebug if u have it)

    Can see it, I think:
    http://s14.postimage.org/fq863x5u9/step2_html_structure.jpg


    3 - The datasource property of the chart is filled with the ds that u generate?


    Yup, it's filled in:
    http://s8.postimage.org/c4o9mpyfp/st...ent_height.jpg

    4 - The Chart have a height property?


    Yup, it has a height:
    http://s8.postimage.org/c4o9mpyfp/st...ent_height.jpg


    More ideas ?

    Any help will be appreciated, Thanks in Advance !
    Last edited by ObjectiveC; 07-05-2012 at 09:25 AM. Reason: link changed

  5. #5

    Default

    Quote Originally Posted by ObjectiveC View Post
    Firts... There is any JS error?

    Everyting seems to be Ok:
    http://s8.postimage.org/b3o0xlhg5/st...ipt_errors.jpg
    Try to see the console tab of fire bug... (Open it and run the dashboard again)...

  6. #6
    Join Date
    Mar 2011
    Posts
    140

    Default

    Hello dguiarj,

    The console does have errors:
    http://s10.postimage.org/huenoujhl/details.jpg
    Last edited by ObjectiveC; 07-05-2012 at 11:04 AM. Reason: link

  7. #7

    Default

    Can u try a table object instead the chart?

  8. #8
    Join Date
    Mar 2011
    Posts
    140

    Default

    Hello dguiarj,

    A table is being rendered, but with the same errors:
    http://s14.postimage.org/rafntbtv5/table.jpg

    Any ideas on why I can't use a bar chart ?

  9. #9

    Default

    Hi,

    A guess?... hummm u propably have charts thats not appropriately conf.... DELETE ALL charts components from ur dashboard... let JUST the table... them (whem it works with NO error) add a chart (in other column)...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.