Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: CSV File output formating problem with number value

  1. #1
    Join Date
    Jul 2012
    Posts
    6

    Default CSV File output formating problem with number value

    Hello
    I'm trying to output data to csv file. Everything is ok beside Number fields:
    Name:  Zrzut_20120712_134005.jpg
Views: 134
Size:  21.8 KB

    In csv file I get:
    Name:  Zrzut_20120712_134131.jpg
Views: 120
Size:  36.1 KB

    How to change decimal symbol from , to . ??

  2. #2

    Default

    Hi,
    When you are dumping data to an output file like csv there is an option 'get fields' in fields tab. Then it automatically selects the types and formats.If you want to specify another format u can try selecting other formats (or) you can directly specify ur required format also. If you are still facing the problem please check the database from which u r dumping data.
    Thanks,
    Sri

  3. #3
    Join Date
    Apr 2009
    Posts
    21

    Default

    Format is determined by locale-settings of environment.
    Overrule by placing desired Decimal separator ('.' in example) in field Decimal
    See screenshot.

  4. #4

    Default

    Hi,
    I tried it and its working for me. Its not showing comma(,) for any decimal values. And i have not found the format in the list which was used by you.
    I think you can do it by selecting the format '00.000'
    If it was not resolved i think you need some senior members help...
    Thanks,
    Sri

  5. #5
    Join Date
    Jul 2012
    Posts
    6

    Default

    Hello
    tvrhgn, placing desired Decimal separator ('.' in example) in field Decimal solved my problem.
    Thanks !!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.