Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Problem with JNDI connection

  1. #1
    Join Date
    Feb 2011
    Posts
    240

    Default Problem with JNDI connection

    Hi,

    I want create a new database connection with Report Designer: connection name = sigi, connection type = postgreSQL, access = JNDI, JNDI Name = SIGI,

    I have modified the file default.properties in the folder: pentaho\design-tools\report-designer\configuration-template\simple-jndi adding the rows: SIGI/type=javax.sql.DataSource
    SIGI/driver=org.postgresql.Driver
    SIGI/url=jdbcostgresql://localhost:1234/sigi_sviluppo
    SIGI/user=sigi
    SIGI/password=password

    But when I create a new connection and I click on test I've this error:

    Errore di connessione al database [sigi] : org.pentaho.di.core.exception.KettleDatabaseException:
    Error occured while trying to connect to the database

    javax.naming.NamingException: Sorgente dati invalida: 'SIGI'
    Sorgente dati invalida: 'SIGI'

    Thanks

    Mariarita

  2. #2
    Join Date
    Dec 2009
    Posts
    609

    Default

    Hi,

    this file is just a template (mind the foldername)

    The file in use is to be found in your Home-Directory/.pentaho:

    on Unix: $HOME/.pentaho/simple-jndi
    on Windows:
    Windows Vista/7: C:/Users/<Username>/.pentaho/simple-jndi
    Windows XP: C:/Documents and Settings/<Username>/.pentaho/simple-jndi

    Edit the file there and restart your report-designer.

    Cheers,

    Tom

  3. #3
    Join Date
    Feb 2011
    Posts
    240

    Default

    Thanks very much

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.